ET running on VISTA - Please help!!!!!!!

I have a HP Pavillion dv9000 notebook with a Geforce GO 7600 video card and running Windows Vista. Everytime I run ET I get the following:

ET 2.60b win-x86 May 8 2006
----- FS_Startup -----
Current search path:
C:\Games\Wolfenstein - Enemy Territory\etmain\zzzscopehess.pk3 (7 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\zzzhessfight.pk3 (5 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\zzsghessloadscrn.pk3 (13 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\zstrimusicmod6.pk3 (6 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\pak2.pk3 (22 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\pak1.pk3 (10 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\pak0.pk3 (3725 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\mp_bin.pk3 (6 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\goldendunk_a2.pk3 (76 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\glider_241.pk3 (49 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\GA_El_Kef.pk3 (39 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\etdo_f1.pk3 (137 files)
C:\Games\Wolfenstein - Enemy Territory\etmain\breakout_360.pk3 (103 files)
C:\Games\Wolfenstein - Enemy Territory/etmain

----------------------
4198 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing profiles/JAMES_T_KIRK/etconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found Intel Pentium III
Bypassing CD checks
--- Common Initialization Complete ---
Winsock Initialized
Opening IP socket: localhost:27960
Hostname: User-PC
IP: 219.77.17.115
IP: 192.168.2.2
Working directory: C:\Games\Wolfenstein - Enemy Territory

The screen just freezes 2 seconds after the game starts (at the intro screen) and stops responding.
Can someone please help??

THANK YOU SO MUCH!