Problem during multiplay


I am having problem with Freelancer when I comes to multiplay.
I join a server ( this happens on all servers) and then I get to planet view.
for now it works.
then I launch to space and I get the red "connection error" image flash and I get booted due to time out or whatever.
All my other online games works fine, I am on a 100mbit internet line with no firewall either.
I play quake3 , world of warcraft. anything
all works. not freelancer tho
anyone know about this problem?

Check the ping of the server before you go into it. With that kind of line, its probably the servers fault. Just try a bunch of different ones.

It could also be possible that something is going wrong if you're using a firewall. So make sure you configure an open port for it.

the ping on the servers I play on is as low as 20.
and I have no problem getting onto the servers.
I can also mention that it worked flawlessly before I reinstalled windows.
And no I dont have any Windows firewall or something more then I had when it worked.

Since I get connection error on ALL servers, I tried setting up my own server.
I join , everything is fine. I launch to space then I see the red connection image. I see it flashing while a few times while I play, tho not as often now , but I still dont get booted from my own server. I look at my server windows and see that I am infact online and the server record my actions.
the problem now is that I am the only one on it , so its not really testing anything is it. so I have to wait till someone joins. the server is called "Domanet"
regular 1.0 server. just join.
And since it is hosted by me, its a "LAN" server for me, so I dont even know if other ppl can see it.
Its supposed to be online tho.

I did a little searching and didnt come up with much. Make sure you've updated to any new patches. I think there might be one, but its been a while since i've played the game...cant remember.

If its a LAN only game, then no, others wont be able to connect to you.

Are you going through a router?

Can you try installing freelancer on another computer and see if that works?

EDIT: heres the link:

Its not a LAN only game. but its marked as a lan to me due to being local here.
I am not going through a router either. I am hooked up straight to the University line , everything else works.
I dont have another computer, no but I dont understand , because it worked 3 days ago. only thing different now is a better pc and new windows.
its a problem with the game it seems , due to eveything else working and not freelancer.
I will try your link.
My server is still up if ppl want to test the connection (pls :P)

I just tried a clean install with the patch
Same problem. Wierd thing tho is that my friend has the exact same problem.
So I thought this was something ppl had encoutered before. He also explains it as getting disconnected everytime he launches to space. He is in a totally different part of the country and on a DSL line and a much older pc.
Still. No difference with patch

Its probably a configuration issue on the machine related to your network. Especially if its happening on more then just your comp. I go to a university and I know that here, they ratelimit almost all the ports except 80 (web).
So try playing the game during non peek hours of the day. Or what would be easier (and if possible) just speek with the on campus network people and maybe they'll be able to let u know if they're blocking something off which is preventing you from playing it. Maybe something new was implimented in the past few days?

To me it looks like freelancer uses a somewhat broad range of ports...anywhere from 1000's to 3000's with the majority of them being in the 2300's.
Might be helpful to ask the techs about that.

Other ppl here play the game. The ports are open.
Also the problem is the same no matte what time of day, and my friend who lives here also can play the game.
at the moment I am running no antivirus or firewall.
I also dont have SP2 installed so there is no windows firewall messing up stuff.
I can also mention that I played the game on this exact connection 3 days ago, that was before I reinstalled windows.
I also tried a reinstall and then manually removing any files with assosiation to freelancer. then I did a clean reinstall and same problem occurs. I tried with patch, and without the patch.
This happens on ALL servers, clean 1.0 servers running no mod. I also got no mod installed, nor any mod tool.
The game works fine in the start at the planet view, but once I lauch to space, I get connection error.
I tried with different graphics drivers and different directx versions. No matter what server, no matte how many times I reinstall. I always loose connection in space mode.
I've tried most solutions, still I cannot play.

Only thing I can think of to do is maybe check the microsfto Knowledge DB. Starting here:;en-us;819836

U can also try to email them the problem as well. If you do ever figure it out, report any solutions here when you can. Murdo or another board member might have additional input to add to this when they come back which may help.

Any solutions yet to this? Thanks.

Running on a cable connection, I've tried with and without the firewall, with/without the router, ..... ARGH!